Leo's weblog

Vampire connector troubles

My Amiga 600 with Vampire V2 is giving me a lot of troubles. When using this A600 I had many crashes, freezes, reboots. It turned out the processor socket of the Vampire did not very well fit on the A600's CPU. It would come off too easily.

After a lot of removing the Vampire and then pushing it on again only made things worse. Then I decided to replace the CPU socket of the Vampire. It did not give any improvement. What's worse, the new socket cracked quite soon. As many other A600 owners seem to have no problems I asked some member of a Dutch Amiga forum to help solving this problem.

I sent him the A600 motherboard with the Vampire. He first replaced the socket again and it turned out that this would not solve the problem of the Vampire coming off. I had an A600 with a different CPU or there had been done some rework: the Vampire would pop off very easily no matter. So the guy offered me a different motherboard that seemed to hold the Vampire better than the old one.

But after a lot of testing I only can say that pushing a socket on the processor is still not ideal and prone to problems. Besides that it is possible that crashes also originate from the OS (Coffin). Not easy to determine.
Having an A500, A1000 or A2000 with a Vampire would be a much better solution! 

The Vampire's price doubled since it's introduction. So I will stick with the A600 and try to make the best of it. That means: open it up often to push the Vampire!

Comments are closed

CommentList